SIMCOM X Voice application

Suggestions, ideas and general discussion about JoinFS.
ATC Roo
Posts: 721
Joined: Sun Oct 16, 2016 9:24 am
Location: UK
Contact:

Re: SIMCOM X Voice application

Post by ATC Roo »

The best way to hear the beep is to transmit for more than 30seconds. Or go into programfiles(x86)/simcomx/sounds/beep.wav

And exactly right with the distance.
Scottish would have been on the equator.

The miles from each client are show in the chat window.

Basic rule of thumb is anything less than 40nm is as you have set your com volume.
Between 40 -200 nm the volume is adjusted based on distance and altitude.
For example:
Somebody 100nm away on the ground would be heard quieter than somebody 100nm away at FL200.

Anything over 200nm isn't heard, with the exception of a _ctr callsign, which will be slightly intermittent or not heard at all.

Did you have more than 2 users in your group btw?
dale152
Posts: 34
Joined: Fri Apr 03, 2020 3:03 pm

Re: SIMCOM X Voice application

Post by dale152 »

Okay, that makes sense.

And yes, there were 3 of us.
User avatar
GianP
Posts: 9
Joined: Tue May 17, 2022 7:19 pm

Re: SIMCOM X Voice application

Post by GianP »

Hi Roo
Tested 3.1.0.2 and .3 on the "usual" config: I-TEST on sim PC and LIMC_TWR - COM1 119.0 on ATC PC tx'ing ATIS - COM2 120.025.
No sim active.
All fine from the connection side but .... lots of voice multi echoing in both directions; + some delay (~3 secs, sometime more!)
I don't remember echo on prev. ver. 3.1.0.1
Also an abend entering config after about 1 minute the App was running (Sim PC)

Ciao
GianP
-------------------
Homepage: gianp.altervista.org ** Homeserver: gianp.onmypc.net (seldom online on internet)
ATC Roo
Posts: 721
Joined: Sun Oct 16, 2016 9:24 am
Location: UK
Contact:

Re: SIMCOM X Voice application

Post by ATC Roo »

Thanks Gian.

I'll revert the voice change I made and again look at the config again.
The config is annoying as that code was the same as the original Simcom X.

If you get the config error again, can you copy and paste it?
User avatar
GianP
Posts: 9
Joined: Tue May 17, 2022 7:19 pm

Re: SIMCOM X Voice application

Post by GianP »

ATC Roo wrote: Mon May 23, 2022 2:07 pmIf you get the config error again, can you copy and paste it?
I think I understand this error! It is consistent when Config window is closed by Win (top right "X"). Next time config is started .... bang!
When Config is "Save"d it never happens.
Tested many-many times now!
BTW, when "Continue" is selected Simcomx continues to run, apparently ok.

Ciao

Attached: My config and error prompt.
Attachments
Config_window.jpg
Config_window.jpg (112.8 KiB) Viewed 1479 times
GianP
-------------------
Homepage: gianp.altervista.org ** Homeserver: gianp.onmypc.net (seldom online on internet)
ATC Roo
Posts: 721
Joined: Sun Oct 16, 2016 9:24 am
Location: UK
Contact:

Re: SIMCOM X Voice application

Post by ATC Roo »

Thanks Gian.

Yes I thought that and made a change last night. 🤞
kc10b747fe
Posts: 54
Joined: Wed Mar 01, 2017 6:04 am

Re: SIMCOM X Voice application

Post by kc10b747fe »

Roo,

Tried 3.1.0.3 this weekend with my flying partner on Join Group Server and SCX mode. In SCX mode sometimes I could see him in the list, but he couldn't see me, and we were never able to establish a chat or voice. On all modes we tried Upnp ticked and unticked. Port forwarding and not port forwarding. In join group server mode we tried using my external IP as host with him using my listening port as his port on the main page of the client and vice versa with no success. On this version I was still able to self test with no problems.

Updated to 3.1.0.4 today, however self test no longer functioned. Tried it on all 3 of my machines with no success. Reinstalled 3.1.0.3, and self test worked again on all machines.

Tony J
User avatar
GianP
Posts: 9
Joined: Tue May 17, 2022 7:19 pm

Re: SIMCOM X Voice application

Post by GianP »

ATC Roo wrote: Tue May 24, 2022 1:23 pmYes I thought that and made a change last night. 🤞
Wow, a very drastic change .... no more X in upper right corner! But it was useless as the Config window can be closed by "SAVe"ing" or by re-clicking the key on the main window.
Version 3.1.0.4 on my test environment (see some post above) works very well, no more echoing, no more huge delays and the devices shown in "config" are those working as foresee.
Hope to find somebody to test online in SCX mode.

Ciao
GP
GianP
-------------------
Homepage: gianp.altervista.org ** Homeserver: gianp.onmypc.net (seldom online on internet)
ATC Roo
Posts: 721
Joined: Sun Oct 16, 2016 9:24 am
Location: UK
Contact:

Re: SIMCOM X Voice application

Post by ATC Roo »

kc10b747fe wrote: Wed May 25, 2022 5:18 pm Roo,

Tried 3.1.0.3 this weekend with my flying partner on Join Group Server and SCX mode. In SCX mode sometimes I could see him in the list, but he couldn't see me, and we were never able to establish a chat or voice. On all modes we tried Upnp ticked and unticked. Port forwarding and not port forwarding. In join group server mode we tried using my external IP as host with him using my listening port as his port on the main page of the client and vice versa with no success. On this version I was still able to self test with no problems.

Updated to 3.1.0.4 today, however self test no longer functioned. Tried it on all 3 of my machines with no success. Reinstalled 3.1.0.3, and self test worked again on all machines.

Tony J
Thanks Tony,

I'm looking at the self test now, it seems to be working but really quiet. Leave it with me.

Regarding the no chat/voice. That would mean you were not connecting to each other for some reason.
Although you have input the details as intended and done everything right, so I'll see if I can replicate it.

Rule of thumb, you can only talk to those shown in the client windows.

Was there anything in the log?

Also Thanks Gian, I'll try and work on things and connect later. But I'm never able to commit to a time at the moment.
ATC Roo
Posts: 721
Joined: Sun Oct 16, 2016 9:24 am
Location: UK
Contact:

Re: SIMCOM X Voice application

Post by ATC Roo »

I managed to find some time, hooraaa!

V3.1.0.5

Fixed Self Test.

Adjusted Distance feature.
Any callsign ending in _CTR greater than 200 miles away won't be heard. Less than 200 miles will be heard as normal.
I'd recommend using the nearest airport icao for a center until the FIR ICAO codes are added. EGLL_CTR for example.

Reenabled and tested the Proxy feature.

Optimised the network side of things to reduce errors.

Tested with the ATC client successfully.
Just polishing the ATC client before releasing it.

Everything should work as intended.

A side note for group mode...
Think of it as host and clients.
The host will need to have a port open.
Forwarding a port is the best way.

Everyone else will then connect to the host.

If your not sure about the port forwarding side of things.
Both clients will need to input each others port and IP.

It'll be tricky if a port isn't open and there are more than 2 users.

I'll sort a group server out at some point to make it easier for people.

Let me know the issues if you get them.
kc10b747fe
Posts: 54
Joined: Wed Mar 01, 2017 6:04 am

Re: SIMCOM X Voice application

Post by kc10b747fe »

Hey Roo,

Had a chance to test v 3.1.0.7 this weekend with my flying buddy however we had no success in making a connection.

Config
FSX checked
Auto Com Switch Checked.
Sound on frequency Checked.
Background noise Checked.
Port Forwarding Port UDP 9988
Listening Port 9988
Upnp Unchecked
Proxy Unchecked

This is what occurred:

1. Self test feature worked with no problems.

2. SCX mode. I was able to see him in the client list but he could not see me. Same result Upnp checked or unchecked.

3. Join group server mode. I was able to see him but again he could not see me. We tried with us both port forwarding
Port UDP 9988 but the results were the same. We also tried him port forwarding a different port (UPD 9200) with the results being the same.
We tried turning off port forwarding and allowing SIMCOM to assign the ports but again the results were the same. We also tried proxy mode.
In this instance I could NOT see him in the client list. Both of our logs indicated no errors, with the only anomaly being, in my log it shows
him being added as a pilot and on his log he didn't have me listed (presumably because we were not connected). Tested with Upnp checked and unchecked.

Since you and I were able to hear and talk to each other on Thursday or Friday, I assumed that the problem may be caused by a
a firewall issue. I went into my router setting and disabled all firewall settings. My buddy did the same on his router, but all results remained
the same.

We use a program called Hamachi which is a virtual network that allows us to establishes a connection over the Internet that emulates the connection that would exist if the computers were connected over a local area network ("LAN"). This program has its own virtual network adapter, and each of us has our own IP address. We tried using these IP addresses as well, with the results being, I was able to see him in the client list but he could not see me.

We also use a program called Voicemeeter, which allows us to stream audio from other programs on our computers to each other. This program is using the Hamachi IP addresses and forwarding port 6980. We are connecting to each other and streaming with no problem. The weird thing is when we use our normal external IP addresses instead of Hamachi in this program, I can receive his stream but he cannot receive mine. All the results for SIMCOM were the same whether these programs were running or not.

We returned to v 2.2.2.5. Connection in SCX mode had no problems. In Host/Join Group mode we could no longer see each other in the client list or make a connection. This was working previously and was our primary means of connecting to each other.

I'm thinking maybe I'm missing something configuration wise, or maybe WIN10 and WIN11 don't want to play nice together. All computers used for testing are WIN10 with the latest build.

Maybe you can steer me to something I haven't thought of?

Hope this helps. I'm usually flying on my computer for a couple of hours most days from around 0830-1030 PDT (7 or 8 hours behind UK time) if you need to test something.

Call Sign N7460TJ. I'll have SIMCOM on listening on frequency 130.600.

Tony J
ATC Roo
Posts: 721
Joined: Sun Oct 16, 2016 9:24 am
Location: UK
Contact:

Re: SIMCOM X Voice application

Post by ATC Roo »

Thanks Tony.

Stick with 2.2.2.5 for the moment.

I've come across a network issue which is probably causing your issues.

I'll release a new version once I've tested my new approach.
dale152
Posts: 34
Joined: Fri Apr 03, 2020 3:03 pm

Re: SIMCOM X Voice application

Post by dale152 »

Hi Roo,

We've got a bit of an event coming up on my server - in case the issues we're having aren't fixed before that time, please could you let me know how to get back to version 2.2.2.5 (if that's the version which used TeamSpeak?). Cheers.

Kind Regards,
Dale
ATC Roo
Posts: 721
Joined: Sun Oct 16, 2016 9:24 am
Location: UK
Contact:

Re: SIMCOM X Voice application

Post by ATC Roo »

Hi Dale,

I'll need to find sometime to fix the issue I noticed.
So for now I've rolled back to 2.2.2.5.

If you download SimcomX now, that's the version you'll get.

I would recommend uninstalling any later versions before downloading the older version.

Otherwise it may complain that a newer version is already installed on your system.

I'll be as quick as poss with the upgraded version, but I want to make sure it's working as intended first.
dale152
Posts: 34
Joined: Fri Apr 03, 2020 3:03 pm

Re: SIMCOM X Voice application

Post by dale152 »

Hi Roo,

Thanks for your help. However, I'm having a bit of trouble opening this version of SIMCOM X. I ran the uninstaller for the latest version and removed every 'Roo' folder in the subfolders of SIMCOM X, as well as from Program Files. Then, I ran the installer for 2.2.2.5, and installed it fine, but it's not opening. After restarting my system, I have tried running it in different compatibility settings to no avail. It doesn't appear in task manager or the hidden icons in the bottom right.

Kind Regards,
Dale
ATC Roo
Posts: 721
Joined: Sun Oct 16, 2016 9:24 am
Location: UK
Contact:

Re: SIMCOM X Voice application

Post by ATC Roo »

It was to do with the update check.
Should be fine now.

Run Uninstaller.
Download latest stable Simcom X.
Run the new installer.
dale152
Posts: 34
Joined: Fri Apr 03, 2020 3:03 pm

Re: SIMCOM X Voice application

Post by dale152 »

Hi Roo,

Interesting. It's still not opening on my system. Might be getting somewhere, however, as it flashes up on my taskbar then immediately closes.

Kind Regards,
Dale
ATC Roo
Posts: 721
Joined: Sun Oct 16, 2016 9:24 am
Location: UK
Contact:

Re: SIMCOM X Voice application

Post by ATC Roo »

Sorry Dale, it's been a busy weekend.

Is it opening and not showing(ie getting stuck minimised)?

If it's in the Task Manager, try right clicking and selecting restore.
Apps getting stuck minimised seems to be a common windows bug if you Google it.

Else if it's not starting at all, is there anything in the log?
dale152
Posts: 34
Joined: Fri Apr 03, 2020 3:03 pm

Re: SIMCOM X Voice application

Post by dale152 »

Hi Roo, no worries. There's nothing in the log bar the creation timestamp. I had a look in task manager. SIMCOM X pops up in Background Processes whenever I double click to open it. It then disappears after a few seconds - when I right clicked there wasn't a restore option, just "End task" alongside other features redundant for our purpose.
dale152
Posts: 34
Joined: Fri Apr 03, 2020 3:03 pm

Re: SIMCOM X Voice application

Post by dale152 »

Hi Roo,

The SIMCOM X client is now working on v2.2.2.5 as we expected. But it only seems to be when it wants to. Last night with 3 of us on we had no issues, yet this afternoon nobody is able to communicate (when we set the same frequency, none of us show up). Nobody has changed any of the settings so I'm not sure what could've caused it.

Kind Regards,
Dale
Post Reply