JoinFS 1.3.0 test

Report problems with JoinFS.
Post Reply
MartinCANCoast
Posts: 35
Joined: Wed Oct 05, 2016 5:27 pm

JoinFS 1.3.0 test

Post by MartinCANCoast »

Tried some multiplayer training tonight. Three pilots all connected to the same node using 1.3.0 and X-Plane 11.10. Learned the following:

- World Traffic 3 must be de-activated (ai conflicts)
- When a pilot changes another pilots Aircraft under VIEW->Aircraft, X-Plane freezes for a moment.
- Had some freezing issues while flying so next test we'll be running the node on a different computer.
- We did try another node but not sure if they were running 1.3.0 or an earlier version, same issue as above though.
- TrackIR also freezes from time to time while in flight.

While testing with 2 pilots on XPlane and one on P3DV4 the P3D Pilot could see the XPlane pilots but one XPlane pilot running the Steam version couldn't see anybody.

Had him try to change the aircraft under VIEW->AIRCRAFT but no difference.

Not sure if the issues relate to the plugin, client or PILOT. But this is a fantastic start Peter, thank you!!!
User avatar
Peter
Site Admin
Posts: 1826
Joined: Fri Sep 23, 2016 8:51 am

Re: JoinFS 1.3.0 test

Post by Peter »

Hi Martin,

thanks for the report.

I'll start a list of plugins that are incompatible. Fortunately it's easy enough to switch plugins on/off as necessary.

I'm not sure I can do anything about the freezes during a model change, that may be just X-Plane loading the aircraft. However, if you had freezes from time to time, then perhaps it's something else. I'll see if I can track it down.

I use X-Plane under Steam so I don't think that was the issue. Did that pilot remember to add sufficient AI aircraft in the flight configuration?

Peter
aenbacka
Posts: 4
Joined: Tue Nov 14, 2017 11:00 am

Re: JoinFS 1.3.0 test

Post by aenbacka »

Hello,

I tried to install the latest test version of JoinFS to test with X-Plane 11. However, when I try to launch the app it directly crashes (exception points to FileNotFound exception). Any idea what could be the reason. Using Windows 10 64-bit.
User avatar
Peter
Site Admin
Posts: 1826
Joined: Fri Sep 23, 2016 8:51 am

Re: JoinFS 1.3.0 test

Post by Peter »

aenbacka wrote:Hello,

I tried to install the latest test version of JoinFS to test with X-Plane 11. However, when I try to launch the app it directly crashes (exception points to FileNotFound exception). Any idea what could be the reason. Using Windows 10 64-bit.
Hi,

Yes, someone else had this problem yesterday. Fortunately I realized what the cause was and have now fixed the problem in version 1.3.1, which will be out later today.

Thanks for posting,

Peter
aenbacka
Posts: 4
Joined: Tue Nov 14, 2017 11:00 am

Re: JoinFS 1.3.0 test

Post by aenbacka »

Hello,

Thanks a lot for the info, looking forward to testing the new version.

Best regards,
Andreas
Peter wrote:
aenbacka wrote:Hello,

I tried to install the latest test version of JoinFS to test with X-Plane 11. However, when I try to launch the app it directly crashes (exception points to FileNotFound exception). Any idea what could be the reason. Using Windows 10 64-bit.
Hi,

Yes, someone else had this problem yesterday. Fortunately I realized what the cause was and have now fixed the problem in version 1.3.1, which will be out later today.

Thanks for posting,

Peter
N953RC
Posts: 6
Joined: Tue Nov 14, 2017 1:24 pm

Re: JoinFS 1.3.0 test

Post by N953RC »

Peter wrote:Hi Martin,

thanks for the report.

I'll start a list of plugins that are incompatible. Fortunately it's easy enough to switch plugins on/off as necessary.

I'm not sure I can do anything about the freezes during a model change, that may be just X-Plane loading the aircraft. However, if you had freezes from time to time, then perhaps it's something else. I'll see if I can track it down.

I use X-Plane under Steam so I don't think that was the issue. Did that pilot remember to add sufficient AI aircraft in the flight configuration?

Peter
First I'd like to thank you for all the work you do for us. I love JoinFS and am testing X-Plane with the guys. Unfortunately I cant seem to get the plugin to work at all. I have tried it on two computers and have completely deleted then re-installed the latest x11 version. Still does not recognize the plugin when added to the plugin folder. I'm running a bare bones stand alone new install with no other addons. This is not the Steam version. My other guys ARE running steam and it works fine for them. Just thought I would let you know there might be a difference between the two. Thanks for being here Peter, you are well appreciated in the flight sim community.

Rick...
User avatar
Peter
Site Admin
Posts: 1826
Joined: Fri Sep 23, 2016 8:51 am

Re: JoinFS 1.3.0 test

Post by Peter »

Hi Rick,

thanks for your kind comments.

How are you installing the plugin? I assume that you've clicked on Install Plugin from File|Settings. After you've done that, go to the X-Plane folder and look in Resources\plugins. You should find a JoinFS folder with 32 and 64 subfolders. In each of those there should be a win.xpl. Then with X-Plane running, go to the enable/disable plugins menu option and you ought to see JoinFS in the list.

Actually, someone else had this problem yesterday and it was unresolved. I wonder if non-Steam X-Plane is somehow different. I'll have a look into it. I doubt that it's anything major.

Peter
MartinCANCoast
Posts: 35
Joined: Wed Oct 05, 2016 5:27 pm

Re: JoinFS 1.3.0 test

Post by MartinCANCoast »

Peter wrote:Hi Martin,

thanks for the report.

I'll start a list of plugins that are incompatible. Fortunately it's easy enough to switch plugins on/off as necessary.

I'm not sure I can do anything about the freezes during a model change, that may be just X-Plane loading the aircraft. However, if you had freezes from time to time, then perhaps it's something else. I'll see if I can track it down.

I use X-Plane under Steam so I don't think that was the issue. Did that pilot remember to add sufficient AI aircraft in the flight configuration?

Peter
Thanks for the reply Peter....We each had 7 AI aircraft in our configuration. Mostly default aircraft or aircraft we had in common. I just installed 1.3.1 and we'll test it again later today.
User avatar
Peter
Site Admin
Posts: 1826
Joined: Fri Sep 23, 2016 8:51 am

Re: JoinFS 1.3.0 test

Post by Peter »

Rick, could you try looking at the file Log.txt in the root X-Plane folder. Search for "JoinFS" within that file. Perhaps there was an error starting the plugin.

Peter
N953RC
Posts: 6
Joined: Tue Nov 14, 2017 1:24 pm

Re: JoinFS 1.3.0 test

Post by N953RC »

Peter wrote:Rick, could you try looking at the file Log.txt in the root X-Plane folder. Search for "JoinFS" within that file. Perhaps there was an error starting the plugin.

Peter

yes i found this --- C:\X-Plane11/Resources/plugins/JoinFS/64/win.xpl : Error Code = 126 : ---


i installed joinfs.. set to run as admin.. rebooted computer.. started joinfs.. went to settings clicked the xplane plugin install..then checked plugin folder and all is there.. rebooted.. loaded xplane and i do have 8 ai's.. fired up joinfs fs and checked the enable/disable plugins but joinfs does not show up.


hope that helps...
Rick...
User avatar
Peter
Site Admin
Posts: 1826
Joined: Fri Sep 23, 2016 8:51 am

Re: JoinFS 1.3.0 test

Post by Peter »

Thanks, Rick, that almost answers the problem. Could you confirm that you see the following files on your system, please.

C:\Windows\System32\msvcr110.dll
C:\Windows\System32\ws2_32.dll
<X-Plane>\Resources\plugins\XPLM_64.dll

And, are you running on 32bit or 64bit Windows?

Thanks,
Peter
N953RC
Posts: 6
Joined: Tue Nov 14, 2017 1:24 pm

Re: JoinFS 1.3.0 test

Post by N953RC »

Peter wrote:Thanks, Rick, that almost answers the problem. Could you confirm that you see the following files on your system, please.

C:\Windows\System32\msvcr110.dll
C:\Windows\System32\ws2_32.dll
<X-Plane>\Resources\plugins\XPLM_64.dll

And, are you running on 32bit or 64bit Windows?

Thanks,
Peter
Peter you found the problem. Thank you so much. I did not have C:\Windows\System32\msvcr110.dll. The computers I used were old win7 that took the free update to w10-64. I just grabbed my newer factory windows 10 box and all are working fine. Sorry I didn't think to do that before bothering you. I'm guessing either the updated windows version had a problem or I installed something that took out that file. You are a busy man. Thank you for taking the time for me.

thanks again,
Rick...
User avatar
Peter
Site Admin
Posts: 1826
Joined: Fri Sep 23, 2016 8:51 am

Re: JoinFS 1.3.0 test

Post by Peter »

Hi Rick,

not at all. Even though I suspected it might be the 110 DLL, it still leaves a bit of a question, because the installer for JoinFS is supposed to check and install 110 if it's missing. So I'm glad you posted because there could still be an issue somewhere that needs sorting out.

Anyway, glad you're up and running.

Peter
N953RC
Posts: 6
Joined: Tue Nov 14, 2017 1:24 pm

Re: JoinFS 1.3.0 test

Post by N953RC »

Peter wrote:Hi Rick,

not at all. Even though I suspected it might be the 110 DLL, it still leaves a bit of a question, because the installer for JoinFS is supposed to check and install 110 if it's missing. So I'm glad you posted because there could still be an issue somewhere that needs sorting out.

Anyway, glad you're up and running.

Peter
A little off topic for here but we are testing in P3D and found that if we are flying planes with mixture control and someone else joins the network with another plane that has mixture control it will sometimes send another planes mixture to 0 shutting down their engine. This doesn't seem to happen with jets of coarse. Fire is getting shut sown with fuel cutoff in his helo. Mixture and fuel cutoff is close. Just something we ran across and thought you would like to know.

Tnx Peter, have a great weekend.

Rick...
N953RC
Posts: 6
Joined: Tue Nov 14, 2017 1:24 pm

Re: JoinFS 1.3.0 test

Post by N953RC »

N953RC wrote:
Peter wrote:Hi Rick,

not at all. Even though I suspected it might be the 110 DLL, it still leaves a bit of a question, because the installer for JoinFS is supposed to check and install 110 if it's missing. So I'm glad you posted because there could still be an issue somewhere that needs sorting out.

Anyway, glad you're up and running.

Peter
A little off topic for here but we are testing in P3D and found that if we are flying planes with mixture control and someone else joins the network with another plane that has mixture control it will sometimes send another planes mixture to 0 shutting down their engine. This doesn't seem to happen with jets of coarse. Fire is getting shut sown with fuel cutoff in his helo. Mixture and fuel cutoff is close. Just something we ran across and thought you would like to know.

Tnx Peter, have a great weekend.

Rick...
Sorry Peter, we just spent the last hr trying to duplicate the symptom but all is working fine now.. tnx for your time. I'll leave ya alone... We'll let you know if we find something definitive..

Rick...
User avatar
Peter
Site Admin
Posts: 1826
Joined: Fri Sep 23, 2016 8:51 am

Re: JoinFS 1.3.0 test

Post by Peter »

Thanks, Rick. I'll continue to look into the problem. I know others are getting it quite frequently.

By the way, I found the cause of the missing dll. JoinFS installs the 32 bit C++ dll, however, the X-Plane plugin requires the 64 bit version. I've updated the manual and the system requirements accordingly.

Peter
Post Reply