No sync of lights, flaps and gear (3.2.13)

Report problems with JoinFS.
Post Reply
CopperNu
Posts: 7
Joined: Sat Sep 03, 2022 4:03 pm

No sync of lights, flaps and gear (3.2.13)

Post by CopperNu »

Hi Peter and all,

when using JoinFS with others, we do not see each other's state of lights and gear reflected properly.
This didn't work between one XP11 and one MSFS user, nor did it work with two XP11 users.
Most of the times it shows the other's model with gear up and lights on, sometimes with gear down with lights off, but there are no changes reflected, no matter what the other does turn on/off.
My Plane.txt for the Variables is unchanged and it is in the selection for the selected model matching model.

Does anyone have this issue as well? Is there anything we can try to fix this? Can the server/hub disable sync of the variables, so is it worth trying another one?

It's pretty annoying flying at night and not having lights on the other's planes.
JoinFS is awesome to have group flights across sims, so I hope there is a solution to this.
Thank you!
CopperNu
Posts: 7
Joined: Sat Sep 03, 2022 4:03 pm

Re: No sync of lights, flaps and gear (3.2.13)

Post by CopperNu »

So using the Monitor mask, I could figure out that the simconnect var "LIGHT STATES" using mask always resulted in 0, it did not react on any of the switches in the sim.
Changing it to the following at least logs the correct reaction on my side in MSFS:

Code: Select all

INTEGER|sim/cockpit/electrical/nav_lights_on|LIGHT NAV|bool|NAV LIGHTS SET|INJECTED
INTEGER|sim/cockpit/electrical/beacon_lights_on|LIGHT BEACON|bool|BEACON LIGHTS SET|INJECTED
INTEGER|sim/cockpit/electrical/landing_lights_on|LIGHT LANDING|bool|LANDING LIGHTS SET|INJECTED
INTEGER|sim/cockpit/electrical/taxi_light_on|LIGHT TAXI|bool|TAXI LIGHTS SET|INJECTED
INTEGER|sim/cockpit/electrical/strobe_lights_on|LIGHT STROBE|bool|STROBES SET|INJECTED
The GEAR HANDLE POSITION is wrongfully depicted as bool in the Plane.txt.
This gives me the correct output (1 on gear down and 1 on flaps full):

Code: Select all

INTEGER|sim/cockpit2/controls/gear_handle_down|GEAR HANDLE POSITION|percent over 100|GEAR SET|INJECTED
FLOAT|sim/flightmodel/controls/flaprat|FLAPS HANDLE PERCENT|percent over 100|FLAPS SET*16383|INJECTED
With these lines, the monitor shows the correct values in the output, but I did not try to test with others yet. I guess others need to have the changes in their Plane.txt as well even if they are using XP11?
CopperNu
Posts: 7
Joined: Sat Sep 03, 2022 4:03 pm

Re: No sync of lights, flaps and gear (3.2.13)

Post by CopperNu »

So we tested, one user on XP11 and I am on MSFS.
With just the above lines in both Plane.txt (it gets reset to the default on each start, so we have to apply the changes after starting JoinFS).

The user on XP11 saw my changes on the Flaps handle position in their Monitor but they were not reflected on the model in XP11. It has always been showing with all lights on, gear up and flaps up in XP11.
MyJoinFS detected all variables correctly:

Code: Select all

04.09.2022 13:56:22.481 - DETECT VARIABLE - OBJECT:1 - flaps handle percent = 0
04.09.2022 13:56:34.481 - DETECT VARIABLE - OBJECT:1 - flaps handle percent = 0,4
04.09.2022 13:56:41.485 - DETECT VARIABLE - OBJECT:1 - flaps handle percent = 0,6
04.09.2022 13:56:42.467 - DETECT VARIABLE - OBJECT:1 - flaps handle percent = 0,8
04.09.2022 13:56:44.466 - DETECT VARIABLE - OBJECT:1 - flaps handle percent = 1
04.09.2022 13:57:04.467 - DETECT VARIABLE - OBJECT:1 - light taxi = 0
04.09.2022 13:57:05.472 - DETECT VARIABLE - OBJECT:1 - light landing = 0
04.09.2022 13:57:05.472 - DETECT VARIABLE - OBJECT:1 - light strobe = 0
04.09.2022 13:57:05.472 - DETECT VARIABLE - OBJECT:1 - light beacon = 0
04.09.2022 13:57:05.472 - DETECT VARIABLE - OBJECT:1 - light nav = 0
None of my changes of lights were shown on the other user's monitor despite my monitor showing them.

From the XP11 user my JoinFS did not show any updates except for the initial state:

Code: Select all

04.09.2022 13:51:22.203 - Injecting aircraft 'C-GTLS' - User '00360-14771-6112/12' - Model 'ToLissA319_V1p6p4' - Sub 'Airbus A320 Neo Asobo AirTraffic 00'
04.09.2022 13:51:22.231 - Aircraft injected 'C-GTLS' - User '00360-14771-6112/12' - ID '5289' - Sub 'Airbus A320 Neo Asobo AirTraffic 00'
04.09.2022 13:51:22.477 - DETECT VARIABLE - OBJECT:5289 - light nav = 1
04.09.2022 13:51:22.477 - DETECT VARIABLE - OBJECT:5289 - light landing = 1
04.09.2022 13:51:22.477 - DETECT VARIABLE - OBJECT:5289 - flaps handle percent = 0
04.09.2022 13:51:22.477 - DETECT VARIABLE - OBJECT:5289 - gear handle position = 0
04.09.2022 13:51:22.477 - DETECT VARIABLE - OBJECT:5289 - light taxi = 1
04.09.2022 13:51:22.477 - DETECT VARIABLE - OBJECT:5289 - light beacon = 1
04.09.2022 13:51:22.478 - DETECT VARIABLE - OBJECT:5289 - light strobe = 1
And this is the state my MSFS reflects - all lights on, gear up (I used Asobo default model to avoid any compatibility issues since the Asobo one works with Multiplayer in MSFS).

My guess is that not only the MSFS variables are wrong in the Plane.txt but also the XP11 variables seem to be.
Since I cannot simulate input from other aircraft into my JoinFS, it's very hard to debug it as a user to figure out on which side and where the error is.
But maybe this input helps you to see the issue?
User avatar
Peter
Site Admin
Posts: 2279
Joined: Fri Sep 23, 2016 8:51 am
Contact:

Re: No sync of lights, flaps and gear (3.2.13)

Post by Peter »

The animations on X-Plane have not been activated yet. JoinFS uses the XPMP2 tools and I think just needs a bit of code to get them working. I will probably get a chance to look at that soon. However, you should be able to see lights etc on MSFS, even when the aircraft are from X-Plane.

The lights seem to work for me in MSFS. Are you referring to X-Plane for that?

The gear handle position works as a bool. Sometimes SimConnect will do the necessary conversion which allows the interface to be used as though it were a bool. Which in the case of JoinFS is more robust than using a percentage.

Be aware that plane.txt is regenerated every time you run JoinFS, so if you need to make changes use your own txt file and modify the file list associated with the aircraft by using the Assign Variables option in the aircraft window.

Are you saying that you didn't see any UPDATE VARIABLE messages in the monitor with X-Plane? (ignoring the fact the changes aren't visible in X-Plane yet). I will just check that now.

Peter
CopperNu
Posts: 7
Joined: Sat Sep 03, 2022 4:03 pm

Re: No sync of lights, flaps and gear (3.2.13)

Post by CopperNu »

Ah, so there are no variables sent to XPlane? Or what do you mean with no animations?

I noticed fact that Plane.txt is regenerated, but I edited it while JoinFS was running and let it re-read it by using the "assign variables..." window and pressing OK, it then updated the behavior based on my changes in Plane.txt, so it works well for testing that way.

When testing, I was on MSFS and a friend was on XPlane. When they joined the Hub, my JoinFS shown the initial state of the variables, but no matter what was done on XPlane, my JoinFS did not get updates neither for lights nor for gear/flaps. And of course MSFS did not reflect that since my JoinFS was not aware of the toggles.

I am not sure what is amiss, at least we know now that sending states *towards* XPlane is not supported yet, so that's one direction covered. But it never worked the other way (even with default Plane.txt for us).
I did not test yet with someone else on MSFS, so when cutting XPlane version out of the equation. Might try that next.

Oh and speaking of variables: Is there somewhere more documentation? Like what does "INJECTED" actually mean? It was added at some point but I couldn't figure out what it's for and how it affects the behavior.
User avatar
Peter
Site Admin
Posts: 2279
Joined: Fri Sep 23, 2016 8:51 am
Contact:

Re: No sync of lights, flaps and gear (3.2.13)

Post by Peter »

Re: Animations. The aircraft are drawn in X-Plane using something called XPXM2. As things stand the JoinFS plugin injects the aircraft into X-Plane but the actual modifications and animations on the model are not yet updated so any variable changes will not be seen in X-Plane simply because the model isn't being updated with that information.

However, another problem has just come to light. I tried testing X-Plane yesterday and it appears that the variables aren't working at all in X-Plane, at least not for me. Your aircraft should have some default variables assigned to it, but they were missing and I was unable to assign any. So I think this must have become broken at some point. I will have a closer look later today. That will explain why it wasn't working the other way because no variable changes would have been generated at the X-Plane end.

Peter
CopperNu
Posts: 7
Joined: Sat Sep 03, 2022 4:03 pm

Re: No sync of lights, flaps and gear (3.2.13)

Post by CopperNu »

Hi Peter,
understood - and thank you a lot for checking this :)

If there is no way to animate right now, can you at least define the way the initial model is injected?
My preference would be to have all lights on and gear down. That way it would look okay-ish on the ground and we could see lights when airborne.
That would improve the look in XPlane as long as there is no animations/changes supported.

If you can find the bug the other way (Xplane -> MSFS) that'd be awesome as well :)

Thanks a lot!
User avatar
Peter
Site Admin
Posts: 2279
Joined: Fri Sep 23, 2016 8:51 am
Contact:

Re: No sync of lights, flaps and gear (3.2.13)

Post by Peter »

The variables on X-Plane are now fixed in v3.2.16, out next week. And the lights, gear and flaps should be working on most X-Plane CSL models that support them in v3.2.17, out the following week.

Peter
CopperNu
Posts: 7
Joined: Sat Sep 03, 2022 4:03 pm

Re: No sync of lights, flaps and gear (3.2.13)

Post by CopperNu »

Thanks a lot, Peter! Looking forward to the updates and will report back once we tested it :)
Post Reply