MSFS - Model Matching - MSFS v 1.15.8.0 - JoinFS 2.2.5

Report problems with JoinFS.
Post Reply
canuck21a
Posts: 59
Joined: Mon May 22, 2017 9:42 pm
Location: Ontario, Canada

MSFS - Model Matching - MSFS v 1.15.8.0 - JoinFS 2.2.5

Post by canuck21a »

Since the latest updates JoinFS has had issues with model matching.

Provided one does not allow JoinFS to run its matching on launch one would likely carry on; however, for me, this was not the case and this is also true for several of my flying buddies who use JoinFS and MSFS.

I have followed the discussions regarding the recent issues and have tried previous versions of JoinFS to see if that helped. That did not help.

Today I installed 2.2.5 on my two MSFS systems; one is Steam and the other is the MS Store version. There was no improvement.

Like others simply choosing the default path yields the minimum models; likely limited to those in the Official folder.
I decided to play around a bit to see if I could coax the beast into submission.
I seem to have managed to overcome some of the issues but with considerable manual additions to the "Other folders to scan:" as well as adding a *.* to the end of the Packages folder. (See image at the end which is the Steam install)

I began by adding the aircraft folders in Community by themselves. This resulted in an increased number of items found.
When trying to substitute I could only find the default versions and not any of the "paints" that had been added.
I then decided to try adding each "paint" folder in turn and seeing if that had any effect on the model count. It did.

So at this moment I have most of my addon aircraft and their related paints working again and I can substitute paints for those models as required.
It actually worked while the sim was alive which was a bonus.

My wonderment is why my manual addition of these folders works and JoinFS cannot seem to figure out how to do this itself like before.
JoinFS_ModelMatching_Upload_May-03-2021.jpg
JoinFS_ModelMatching_Upload_May-03-2021.jpg (153.36 KiB) Viewed 309 times
canuck21a
Posts: 59
Joined: Mon May 22, 2017 9:42 pm
Location: Ontario, Canada

Re: MSFS - Model Matching - MSFS v 1.15.8.0 - JoinFS 2.2.5

Post by canuck21a »

I have since discovered that the Official paints are not available.

I added these to my scan list to get the A320's to show as they should when I changed aircraft in the sims

Steam
G:\MicrosoftFlighSimulator\Official\Steam\asobo-aircraft-a320-neo-livery-aviators
G:\MicrosoftFlighSimulator\Official\Steam\asobo-aircraft-a320-neo-livery-global
G:\MicrosoftFlighSimulator\Official\Steam\asobo-aircraft-a320-neo-livery-orbit
G:\MicrosoftFlighSimulator\Official\Steam\asobo-aircraft-a320-neo-livery-pacifica
G:\MicrosoftFlighSimulator\Official\Steam\asobo-aircraft-a320-neo-livery-s7
G:\MicrosoftFlighSimulator\Official\Steam\asobo-aircraft-a320-neo-livery-worldtravel

OneStore
E:\Microsoft Flight Simulator\Official\OneStore\asobo-aircraft-a320-neo-livery-aviators
E:\Microsoft Flight Simulator\Official\OneStore\asobo-aircraft-a320-neo-livery-global
E:\Microsoft Flight Simulator\Official\OneStore\asobo-aircraft-a320-neo-livery-orbit
E:\Microsoft Flight Simulator\Official\OneStore\asobo-aircraft-a320-neo-livery-pacifica
E:\Microsoft Flight Simulator\Official\OneStore\asobo-aircraft-a320-neo-livery-s7
E:\Microsoft Flight Simulator\Official\OneStore\asobo-aircraft-a320-neo-livery-worldtravel

Now when I change A320 aircraft in either sim the correct model shows in the other sim.

When i wish to substitute in JoinFS I need to use the "Select a type:" as they show up as different types and not as variations to the base model.
User avatar
Peter
Site Admin
Posts: 1830
Joined: Fri Sep 23, 2016 8:51 am

Re: MSFS - Model Matching - MSFS v 1.15.8.0 - JoinFS 2.2.5

Post by Peter »

You should not have the "\*.*" at the end of the root folder. That will actually stop it from working. It should just read "G:\MicrosoftFlighSimulator".

I added the specific folders to my Other Folders list but it made no difference to the number of models found. I get 122 models with just the root folder and nothing else set in the window.

Peter
canuck21a
Posts: 59
Joined: Mon May 22, 2017 9:42 pm
Location: Ontario, Canada

Re: MSFS - Model Matching - MSFS v 1.15.8.0 - JoinFS 2.2.5

Post by canuck21a »

Thanks for the reply Peter; however, I continue to have issues.

I did use the "G:\MicrosoftFlighSimulator" but it found only 61 models. That was one of my first tries.
When I try to substitute an A320 all I get is the A320 and the neo paint as the single item to use.
Where are all of the new Asobo paints in the Official folder? They did not appear.

It is also true that if I put additional folders in the list and leave that root folder in place the results are the same.
But !
When I add \*.* or \* to the root folder then the listed additional folders yield results and the count jumps to 85 and I have more items to use as substitutes including the Asobo new paints for the A320 as "types". I then can assume that if I add all of the folders for various paints then my count will go back to what it was before all of this issue started.

This is perplexing as you do not seem to have any issues save for maybe your comment on "Other Folders" not making a difference in your case. Should you have expected more models/paints to be added?
User avatar
Peter
Site Admin
Posts: 1830
Joined: Fri Sep 23, 2016 8:51 am

Re: MSFS - Model Matching - MSFS v 1.15.8.0 - JoinFS 2.2.5

Post by Peter »

Yes, it is very strange that the same operation on my machine is yielding different results. Could we look into it on Discord tomorrow (Wednesday) at a convenient time?

Peter
canuck21a
Posts: 59
Joined: Mon May 22, 2017 9:42 pm
Location: Ontario, Canada

Re: MSFS - Model Matching - MSFS v 1.15.8.0 - JoinFS 2.2.5

Post by canuck21a »

I can be on Discord tomorrow (Wednesday). I am usually available after 1300 GMT (0900 EDT). Just let me know when you would like me to be there. If you want we can use TeamViewer to make things easier?
User avatar
Peter
Site Admin
Posts: 1830
Joined: Fri Sep 23, 2016 8:51 am

Re: MSFS - Model Matching - MSFS v 1.15.8.0 - JoinFS 2.2.5

Post by Peter »

canuck21a wrote: Tue May 04, 2021 5:49 pm I can be on Discord tomorrow (Wednesday). I am usually available after 1300 GMT (0900 EDT). Just let me know when you would like me to be there. If you want we can use TeamViewer to make things easier?
1300GMT would be great. See you on the JoinFS Discord server. We could use the Discord window streamer if necessary.

Peter
User avatar
Peter
Site Admin
Posts: 1830
Joined: Fri Sep 23, 2016 8:51 am

Re: MSFS - Model Matching - MSFS v 1.15.8.0 - JoinFS 2.2.5

Post by Peter »

An update for anybody following this thread. We managed to find the cause of the problem for this particular case. Hopefully this is the same cause for everyone having this issue.

The cause of the problem was due to a broken OrbX hard folder link in the Community folder. You can verify if this is the case for you by doing a manual 'File|Scan For Models' with the root folder set as intended (packages), then look at View|Monitor and see if you have a 'Failed to search folder' message. If you do then that specified folder is the broken link. You can manually fix the broken link to resolve the issue. But I will also be modifying the JoinFS code to handle this situation, and instead of throwing away all the current scanned models when this error occurs, it will display the message but keep all the models currently found, so this will no longer be an issue.

Peter
canuck21a
Posts: 59
Joined: Mon May 22, 2017 9:42 pm
Location: Ontario, Canada

Re: MSFS - Model Matching - MSFS v 1.15.8.0 - JoinFS 2.2.5

Post by canuck21a »

After we completed our testing I turned my attention to the other system that exhibited similar matching issues.

That system also had the same bad link. I removed it, started MSFS, then JoinFS followed by a scan. It found all of the models this time.
canuck21a
Posts: 59
Joined: Mon May 22, 2017 9:42 pm
Location: Ontario, Canada

Re: MSFS - Model Matching - MSFS v 1.15.8.0 - JoinFS 2.2.5

Post by canuck21a »

As I had mentioned I have a friend that is also having model matching issues.
I was able to get on his system and go through the various scanning scenarios to try to weed out the culprit(s).

I did find two models in his Community folder that generated errors. I removed them and then rescanned the Community. All good !

I then tried his Official folder. Not so good.
The scan crashed on the C208 addons paints from Asobo. I removed each one in succession and each time the scan crashed on the next one. After all the Asobo addon paints were gone leaving the base C208 aircraft the scan worked without a problem.

I then set the scan back to the root and bingo...he had 274 models. (lots of addon paints in Community)

I think that re-installing the C208 paints followed by a PC restart, etc. might result in a good scan but for now he is happy.

A bit of the Monitor screen when a C208 error occurred:

05/05/2021 14:25:03.604 - Starting model scan...
05/05/2021 14:25:04.196 - Failed to search folder.Could not find a part of the path 'C:\Users\xxxx\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalCache\Packages\Official\OneStore\asobo-aircraft-208b-grand-caravan-ex-livery-kenmore\SimObjects\Airplanes\Asobo_208B_GRAND_CARAVAN_EX_Livery_Kenmore\texture.kenmore'.
05/05/2021 14:25:04.196 - Scan found 32 model(s)
05/05/2021 14:25:04.197 - Loaded 8 substitution(s)
05/05/2021 14:25:04.197 - Loaded 0 model masquerades
User avatar
Peter
Site Admin
Posts: 1830
Joined: Fri Sep 23, 2016 8:51 am

Re: MSFS - Model Matching - MSFS v 1.15.8.0 - JoinFS 2.2.5

Post by Peter »

canuck21a wrote: Wed May 05, 2021 9:30 pm 05/05/2021 14:25:03.604 - Starting model scan...
05/05/2021 14:25:04.196 - Failed to search folder.Could not find a part of the path 'C:\Users\xxxx\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalCache\Packages\Official\OneStore\asobo-aircraft-208b-grand-caravan-ex-livery-kenmore\SimObjects\Airplanes\Asobo_208B_GRAND_CARAVAN_EX_Livery_Kenmore\texture.kenmore'.
05/05/2021 14:25:04.196 - Scan found 32 model(s)
05/05/2021 14:25:04.197 - Loaded 8 substitution(s)
05/05/2021 14:25:04.197 - Loaded 0 model masquerades
When looking at that folder in Windows File Explorer are there any issues similar to the broken link problem from earlier?

I am going to rewrite the search code anyway, so hopefully this will not be a problem either.

Peter
canuck21a
Posts: 59
Joined: Mon May 22, 2017 9:42 pm
Location: Ontario, Canada

Re: MSFS - Model Matching - MSFS v 1.15.8.0 - JoinFS 2.2.5

Post by canuck21a »

I was focused on checking for corrupted links but there were none reported.
All errors that came up were associated with issues in model folders similar the one that I posted.
User avatar
Peter
Site Admin
Posts: 1830
Joined: Fri Sep 23, 2016 8:51 am

Re: MSFS - Model Matching - MSFS v 1.15.8.0 - JoinFS 2.2.5

Post by Peter »

If anyone would like to try the fix for the scan issue, please try the test version 2.2.6, https://joinfs.net/development.html

Peter
canuck21a
Posts: 59
Joined: Mon May 22, 2017 9:42 pm
Location: Ontario, Canada

Re: MSFS - Model Matching - MSFS v 1.15.8.0 - JoinFS 2.2.5

Post by canuck21a »

I will have a go at it.
canuck21a
Posts: 59
Joined: Mon May 22, 2017 9:42 pm
Location: Ontario, Canada

Re: MSFS - Model Matching - MSFS v 1.15.8.0 - JoinFS 2.2.5

Post by canuck21a »

I have completed some tests with V 2.2.6 TEST.
1.) Ran scan on sim as presented. Model count matched v 2.2.5
2.) Added an Asobo A320 paint to the Community
3.) Scan found one more model
4.) Ran FBW Installer (to create new FBW paint), 1 model found and converted
5.) Scan one more model
6.) Removed Asobo A320 Paint and rescan. One less model found
7.) Removed 5 Asobo 747-8 paints, scan found 5 less models
8.) Re-installed 747 paints, scan found 5 more models
9.) Restored the corrupted Community scenery link that caused issues last week.
10.) Scan ran without issue with the same count as prior to adding the link back in.

This series of tests seem to suggest that whatever was gong wrong on my system has been resolved.

When 2.2.6 is released I will return to my friend's PC, re-install the Asobo paints that were removed and see if JoinFS is happy again on that system.
User avatar
Peter
Site Admin
Posts: 1830
Joined: Fri Sep 23, 2016 8:51 am

Re: MSFS - Model Matching - MSFS v 1.15.8.0 - JoinFS 2.2.5

Post by Peter »

canuck21a wrote: Wed May 12, 2021 1:40 pm I have completed some tests with V 2.2.6 TEST.
1.) Ran scan on sim as presented. Model count matched v 2.2.5
2.) Added an Asobo A320 paint to the Community
3.) Scan found one more model
4.) Ran FBW Installer (to create new FBW paint), 1 model found and converted
5.) Scan one more model
6.) Removed Asobo A320 Paint and rescan. One less model found
7.) Removed 5 Asobo 747-8 paints, scan found 5 less models
8.) Re-installed 747 paints, scan found 5 more models
9.) Restored the corrupted Community scenery link that caused issues last week.
10.) Scan ran without issue with the same count as prior to adding the link back in.

This series of tests seem to suggest that whatever was gong wrong on my system has been resolved.

When 2.2.6 is released I will return to my friend's PC, re-install the Asobo paints that were removed and see if JoinFS is happy again on that system.
Thanks for the update. It sounds as though it is fixed. And thanks for helping to identify the cause :)

Peter
Post Reply